Битрикс обновление jquery (регистрация новой версии)

Битрикс по умолчанию юзает версию jquery 1.8, чтобы заменить ее на любую другую нужно произвести ее перерегистрацию.
Для этого в файле Init.php добавляется следующий обработчик:

emptyHack — для обхода некого битрикс бага касательно первого CJSCore::Init();
/bitrix/js/main/jquery/jquery-1.12.4.min.js — это путь до jquery файла с новой версией загруженного на сервер или с googleapis;

далее в шаблоне сайта или в каком либо компоненте:

и больше не надо нигде никаких:

или

Битрикс обновление jquery (регистрация новой версии): 2 комментария

  1. Анатолий

    Добрый день! А если нет файла init.php? Я создал его сам, написал по вашему рецепту, но всё ровно показывается версия 1.8.3 у jquery.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *